Attention, ces iPhone risquent de ne plus fonctionner à partir du 3 novembre

Apple avertit les utilisateurs que certains modèles d’iPhone et d’iPad d’ancienne génération risquent de ne plus marcher à partir du 3 novembre prochain en raison d’un bug. La firme recommande ainsi une mise à jour du système de l’appareil concerné afin d’y remédier.

L’iPhone est sans aucun doute l’une des gammes de smartphones les mieux implantées sur le marché. Malgré le fait qu’Apple ait récemment annoncé les iPhone 11 qui ont été salués pour leurs performances et leur élégance, de nombreuses personnes utilisent encore des terminaux iOS d’ancienne génération. Ces dernières, notamment les possesseurs d’iPhone et d’iPad sortis avant 2012, risquent cependant de plus pouvoir continuer à se servir de leur périphérique de manière convenable à partir de la semaine prochaine.

Crédits Pixabay

Comme le souligne idropnews.com, cela est dû à un bug touchant le GPS.

En substance, ce dernier horodate ses données de manière à ne lui permettre d’atteindre que 1 023 semaines avant de revenir à zéro.

Une mise à jour pour régler le problème

Le bug a été découvert en avril dernier, mais ce n’est que maintenant que la Pomme nous avertit des conséquences possibles. Selon elle, le problème aura une incidence sur certains iPhone et iPad juste avant le 3 novembre 2019, à minuit GMT. Il faut savoir qu’en plus de corrompre les données de géolocalisation, un dysfonctionnement du GPS est susceptible de fausser le réglage automatique de l’heure et de la date. Cela peut entraîner des problèmes de synchronisation de certaines applications.

Face à cette situation, Apple nous conseille de mettre à jour le système de notre appareil. « Il est particulièrement important de mettre à jour le logiciel de votre appareil avant le 3 novembre pour s’assurer que son GPS, sa date et son heure continuent de fonctionner correctement », a-t-elle écrit dans une note à destination des utilisateurs.

Quels sont les terminaux concernés ?

Comme indiqué plus haut, le bug ne touche pas l’ensemble des gammes iPhone et iPad. Il affecte principalement les modèles ayant été lancés avant 2012.

Aussi, seul l’OS des terminaux suivants a besoin d’être mis à jour : iPhone 5, iPad de 4e génération, iPhone 4s, iPad Mini de première génération, iPad 2 (modèles CDMA uniquement) et iPad de 3e génération. Concernant en particulier les iPad, ce sont les variantes compatibles cellulaires qui doivent faire l’objet d’une MAJ.

Mots-clés appleiphone